Announcement

Collapse
No announcement yet.

Problems with Juki Speed Control Box

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problems with Juki Speed Control Box

    Has anyone else had the same problem that I have had with my new gracie SR2 frame and my Juki TL98Q Machine? When we set up the frame and plugged in the machine, it would not run when the start button was pushed. I had to jiggle the machine to get it started. It would sew fine but then would not start up the next time I pushed the button. They sent two replacements but I had the same problem with them. It seems to be something like a short in the wire or the box. But 3 all having the same problem??? Any ideas?

    #2
    Re: Problems with Juki Speed Control Box

    It sounds like you are going to have to return the machine. Surely 3 out of 3 control boxes couldn't be defective, could they?

    Comment


      #3
      Re: Problems with Juki Speed Control Box

      Actually, my machine is fine. I have had it for a few years and it works fine with the foot pedal. It only happens with the control box plugged into the machine. I agree that 3 out of 3 is a bit weird. Will call them again.

      Comment


        #4
        Re: Problems with Juki Speed Control Box

        You might check if there are dip switches that need to be set for your specific machine. Dip switches are tiny, tight, little switches, usually located internally. On my generic speed controller, I have to set the dip switches depending on the machine I'm using.
        Toni ... If I keep sewing long enough, will they make their own dinner?

        Comment


          #5
          Re: Problems with Juki Speed Control Box

          You have to move your machine on the frame for it to work. Yes the regulated works..but it only moves when you move..I have same machine on a king grace frame

          Comment


            #6
            Re: Problems with Juki Speed Control Box

            This link, Grace Speed Control Instructions , is to a PDF document showing how the switches need to be set for various brands of sewing machines. Setting 1 is for a Juki.
            Originally posted by GuitarGramma View Post
            You might check if there are dip switches that need to be set for your specific machine. Dip switches are tiny, tight, little switches, usually located internally. On my generic speed controller, I have to set the dip switches depending on the machine I'm using.
            *~* Myrna *~*
            *~* Quilters lead pieceful lives *~*

            Comment


              #7
              Re: Problems with Juki Speed Control Box

              They supposedly set it before they sent it to me. I will check it out though. Thanks for your help!!

              Comment


                #8
                Re: Problems with Juki Speed Control Box

                I took the control cover off and mine does not look like that at all. They possibly changed them. Even though the outside looks exactly like the one pictured, the inside is a circuit board type piece that does not have anything you can change. I will contact them again and ask for some more assistance. The tech guy I talked to said it might be a short in either the wire or the box. Will let you all know what I learn. Thanks again. Brenda

                Comment


                  #9
                  Re: Problems with Juki Speed Control Box

                  Thought I would let you all know what I have discovered about the speed control box that came with the Grace SR2 frame. For some reason it was very finicky about starting when I pushed the on button. After playing with it for some time, I discovered that the On Button was sticking when I pushed it in. I started popping it with my thumb nail to make it unstick and discovered that on the third pop , it would start running. So, I now pop that button 3 times with my thumbnail to make it start. I need to call them back and ask some more questions and tell them what it is doing now. But, at least I have it running now.
                  Last edited by Quiltlover; October 13, 2016, 10:43 AM. Reason: misspelled words

                  Comment

                  Working...
                  X