Announcement

Collapse
No announcement yet.

Yipes! That never happened before!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Re: Yipes! That never happened before!

    I should have said it was caught under the sewing cabinet. Can't talk on the phone and type, too. Lol

    Comment


      #17
      Re: Yipes! That never happened before!

      This happened once to me. Looked down and my dog was laying on it! LOL Good thing I didn't have my fingers in the way.

      Never thought about cleaning it. I bet mine will have some dirt/lint/hair in there. Thanks for the heads up in case it happens for real next time.
      Vonnie

      Comment


        #18
        Re: Yipes! That never happened before!

        Thanks, Everyone! Love that I can always count on my quilty friends for great advice!
        Hope you all had a lovely Thanksgiving!
        Blessings,
        ~ Sally \0/

        Comment


          #19
          Re: Yipes! That never happened before!

          Not on a sewing machine, but...similar issue. The foot pedal had something stuck in it..like in the side area between what is pressed down and what stay put. I cleaned it out and worked fine. Ormaybe the pedal just needs a little oil on the hinges. Lot of dust and lint bunnies down there on the floor to dry things out! Or, maybe check to see if it is plugged in to the machine completely. I had the opposite happen on my machine tho...I pressed and it started, but I wanted it faster and pressed harder and it didn't go any faster. Problem.....pedal was half off the mouse pads I have it sitting on so it doesn't slip around on the carpet. So as I pressed harder, the carpet was pressed down, not allowing a stable surface for the pedal to press on.
          Cheri

          www.fabricandmemories.blogspot.com

          Comment

          Working...
          X